Chevrolet Silverado 1500 / 2500 / 3500:

Troubleshooting no elect power in my truck

You are not logged in.

# 1  1/11/2015 8:48 PM

bkoutlaw
New member
Registered: 1/11/2015
Posts: 1

Troubleshooting no elect power in my truck

My 2000 Silverado decided not to start. Nothing works due to no elect power. Had battery tested and it is good.

All connections seem tight no lights work.....nothing.

Please Help!

Offline

 

# 2  1/12/2015 4:01 PM

TechHelp2
Administrator
Registered: 11/24/2009
Posts: 1299

Re: Troubleshooting no elect power in my truck

Clean your battery cables ends on both sides of the battery then go to the battery cable junction block and clean them also.

Check your ignition fuse A 40 AMP fuse (IGN 40 AMP) and the ignition C fuse (ING 20 AMP) fuse in the under hood fuse block.

Check the Mega fuse 125 AMP also.

In the electrical circuit is a fusible link; if this is blown you won't have power to the truck. I listed a schematic below.

https://www.realworldautomotive.com/forums/uploads/thumbs/174_85085992.gif

Try these suggestions and get back to me with your results.

Schematic supplied by Alldata information website.


realworldautomotive.com
car and truck information like nowhere else

Offline

 
E-mail Page
Print Page
Save or Share Information
ALLDATAdiy.com is the leading source of factory diagnostic & repair information specific to your car.

Powered by PunBB
Copyright © 2007-  RealWorldAutomotive.com

Save or Share Automotive Information
Custom Search