Ford Expedition:

Fuel/Electrical Problem

You are not logged in.

# 1  5/1/2012 1:23 AM

bishopp47
New member
Registered: 3/22/2012
Posts: 1

Fuel/Electrical Problem

Hi guys, this is my first post on the forum. I’m working on a customer’s Ford Expedition. the vehicle wouldnt start and after i ran some tests it seemed as though the fuel pump was not working, so I replaced it with a new one but still had the same issue. We also replaced the crankshaft position sensor. Checked fuses, everything was okay. But the car is still not starting. Is there anyone that can give me some advice on what I need to be looking for? Thank you.

Offline

 

# 2  5/1/2012 1:38 AM

TechHelp2
Administrator
Registered: 11/24/2009
Posts: 1299

Re: Fuel/Electrical Problem

First thing we need is more information like the year, engine size, model or series and a list of the tests that you performed so far.

If you don't have fuel pressure because of no voltage to the fuel pump it could be a few other things like the fuel pump relay, PCM, faulty wiring the list can go on.

You never said if you had spark or not, if you have spark and no fuel pressure then the fuel system electrical circuit would need to be investigated.

With the proper details you supply me about the problem the better I can help you.

Get back to me with this important information when you can.


realworldautomotive.com
car and truck information like nowhere else

Offline

 
E-mail Page
Print Page
Save or Share Information
ALLDATAdiy.com is the leading source of factory diagnostic & repair information specific to your car.

Powered by PunBB
Copyright © 2007-  RealWorldAutomotive.com

Save or Share Automotive Information
Custom Search