Mercury Grand Marquis:

1997 Mercury Grand Marquis

You are not logged in.

# 1  7/11/2011 2:13 PM

doubled478
New member
Registered: 7/11/2011
Posts: 1

1997 Mercury Grand Marquis

Something is draining the battery. I put a test light between the negative cable and the negative post and have power, I tried pulling each fuse individually and each relay and circuit breaker and never lost power.

Offline

 

# 2  7/12/2011 3:13 AM

TechHelp2
Administrator
Registered: 11/24/2009
Posts: 1305

Re: 1997 Mercury Grand Marquis

The alternator and the starter are on a fuse link circuit that pulls power from the battery before the fuse panel. Try to disconnect the power from the alternator to see if the light goes out, if not then disconnect the starter solenoid power.

Did you disconnect any circuit breakers to see if the light went out?

Try these suggestions and let me know how you make out.


realworldautomotive.com
car and truck information like nowhere else

Offline

 

# 3  7/12/2011 11:25 PM

way2old
Senior Member
Registered: 9/17/2009
Posts: 30

Re: 1997 Mercury Grand Marquis

This may sound stupid, but did you have the hood lamp out of the socket or disabled?  Also was any of the doors open when you were testing?  I pulled a lot of hair out by missing the little simple things.


Being way2old is why I need help from younger minds.
People are like slinkys, not much use but I still smile when I see one stumble down the stairs.

Offline

 
E-mail Page
Print Page
Save or Share Information
ALLDATAdiy.com is the leading source of factory diagnostic & repair information specific to your car.

Powered by PunBB
Copyright © 2007-  RealWorldAutomotive.com

Save or Share Automotive Information
Custom Search