Mitsubishi Eclipse:

Have to push the rpms way to drive

You are not logged in.

# 1  3/3/2011 4:03 AM

notrdam844
New member
Registered: 3/3/2011
Posts: 1

Have to push the rpms way to drive

I have a 2000 Mitsubishi eclipse. As of about a month ago it started driving kinda odd. It started having slow acceleration issues. I usually stay around mid to low rpms and have lots of power now even in reverse I have little power and have to rev the rpms almost up to red line to get it to go. It is a five speed and it takes a while to get up to speed but once there I can maintain it just hard to go any faster. The check engine said the map sensor was an error code so I replaced it. I replaced all plugs and wires, mass air flow and filter and one of the O2 sensors still no power. 

            Please Help

Offline

 

# 2  3/3/2011 3:13 PM

TechHelp2
Administrator
Registered: 11/24/2009
Posts: 1299

Re: Have to push the rpms way to drive

Did you check the fuel pressure?

A clogged fuel filter can cause a no power problem.

Check the fuel pressure, low fuel pressure or fuel volume can also contribute to the problem.

It is rare but a bad knock sensor will retard the ignition timing. Rescanning the computer and look at the knock sensor and timing parameters will help find the problem.

Try these few suggestions and get back to us with the results.


realworldautomotive.com
car and truck information like nowhere else

Offline

 
E-mail Page
Print Page
Save or Share Information
ALLDATAdiy.com is the leading source of factory diagnostic & repair information specific to your car.

Powered by PunBB
Copyright © 2007-  RealWorldAutomotive.com

Save or Share Automotive Information
Custom Search